gufaba.com

loadding ...

通达信组合副图指标公式

2017-04-20 17:01

  通达信组合副图指标公式

N:=2;
M:=3;
ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//散户套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}
ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}   
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}
ZSHJJ:=EMA(ZSHTL,89);{//散户警戒}
ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
{散户筹码警戒}
   STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,2,0),COLOR00FF00;
{顶部:(ZZLKP>75),COLORFFFFFF;}
{主力筹码警戒}
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,2,0),COLORRED;
实心红柱:(ZZLJJ>REF(ZZLJJ,1))>0,COLORRED;
散筹因子:INTPART(ZSHTL),COLORCYAN,LINETHICK1;
主筹因子:INTPART(ZZLKP),COLORWHITE,LINETHICK1;
0,DOTLINE,COLORGRAY;   
20,DOTLINE,COLORGRAY;
50,DOTLINE,COLORGRAY;
100,DOTLINE,COLORGRAY;
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSV4:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
短期B:=SMA(RSV1,3,1);
短期A:=SMA(短期B,3,1);
K4:=SMA(RSV4,8,1);
   中期波段:SMA(K4,3,1),LINETHICK0,COLORWHITE;
VV1:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1);
VV2:=SMA(VV1,3,1);
VV3:=3*VV1-2*VV2;
趋势:=EMA(VV3,3);
VV4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
准备资金:IF(趋势<13,1,0),LINETHICK0,COLORCYAN;
开始    建仓:IF(趋势<13 AND VV4>13,1,0),LINETHICK0,COLORYELLOW;
VA1:=(CLOSE*2+HIGH+LOW)/4*10; 
VA2:=EMA(VA1,13);
VA3:=EMA(VA1,34);
VA4:=VA2-VA3;
VA5:=EMA(VA4,5);
VA6:=2*(VA4-VA5)*5.5;
主力进场:IF(VA6>=0 AND 趋势<13,1,0),LINETHICK0,COLORFF00FF;
   转折:=IF(REF(中期波段,1)<REF(中期波段,2) AND 中期波段>REF(中期波段,1),1,0);
先机共振抄底:IF(开始建仓=1 AND 主力进场=1 AND 中期波段>REF(中期波段,1),1,0),COLORRED,LINETHICK0;
短线波段:IF((转折=1 AND 短期B>=短期A) OR (REF(短期B,1)<REF(短期A,1) AND 短期B>=短期A AND 中期波段>REF(中期波段,1)),1,0),LINETHICK0,COLOR0080EF;
STICKLINE(短期B>=短期A,短期A,REF(短期A,1),3,0),COLOR0080EF;
STICKLINE(短期B<短期A,短期A,REF(短期A,1),3,0),COLORFF6600;
DRAWICON(先机共振抄底=1,REF(短期A,1),1);
DRAWICON(短线波段=1 AND 先机共振抄底=0,REF(短期A,1),7);
   SMA(K4,3,1),COLORGREEN,LINETHICK3; IF(中期波段>REF(中期波段,1),中期波段,DRAWNULL),LINETHICK3,COLORRED;
STICKLINE(准备资金=1,3,-2,5,0),COLORCYAN;
STICKLINE(开始建仓=1,10,-2,5,0),COLORYELLOW;
STICKLINE(主力进场=1 AND 开始建仓=1,6,-2,5,0),COLORFF00FF;

  以上信息由股发吧网的小编为您提供,股发吧网的小编感谢您对股发吧网的支持。

  

相关文章

热门文章